Как узнать IP адрес компьютера?

Для более глубокого изучения 1С скачайте книгу "Программирование в 1С за 9 шагов"

В этой небольшой статье узнаем IP-адрес текущего компьютера средствами 1С Предприятие с использованием COM-объекта WbemScripting. Итоговая функция для получения IP-адреса выглядит так:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
Функция ПолучитьIPАдрес()
 
	strComputer = ".";
	SWBemlocator = Новый COMОбъект("WbemScripting.SWbemLocator");
	objWMIService = SWBemlocator.ConnectServer(strComputer, "root\CIMV2");
	IPConfigSet = objWMIService.ExecQuery("Select IPAddress from Win32_NetworkAdapterConfiguration where ipenabled = true");
 
	Для Каждого Конфигурация Из IPConfigSet Цикл
		Для Каждого СтрПараметр Из Конфигурация.IPAddress Цикл 
			Возврат СтрПараметр;
		КонецЦикла;
	КонецЦикла;
 
КонецФункции;

Функция получает параметры конфигурации локальной сети и возвращает адрес компьютера.

К примеру, если локальный адрес (Ethernet address) компьютера у вас 192.168.0.5, а адрес выхода в глобальную сеть (Internet address) 178.215.178.135, то функция вернёт именно локальный адрес.

Обработку 1С определения IP-адреса компьютера можно скачать по ссылке ниже.

ip_address

Свои вопросы и предложения по использованию этого метода определения сетевого адреса оставляйте в комментариях ниже.

Скачать

 

Нравится статья? Подпишитесь прямо сейчас и получайте обновления на свой E-Mail:

БЕСПЛАТНЫЕ материалы по изучению конфигурации 1С:Бухгалтерия 8 (ред. 2 и новая ред. 3)

Распечатать статью Распечатать статью